I am using QuickBooks® 2007 or earlier. Do I need to upgrade?

If you email documents from QuickBooks®, use on line banking or run payroll in QuickBooks® you will need to upgrade your software to at least the 2008 version, which for most means 2010. If not, you can continue to use 2007, but keep in mind that Intuit will stop issuing maintenance releases. Maintenance releases are different than program upgrades, maintenance releases “fix” program glitches and keep the program updated to work with the latest operating systems and other programs. Folks used to be able to use QuickBooks® well past the sunset date, but the use of email and on line banking have made upgrading a necessity for most people.

Leave A Response